ansible_diversity_working_group_|_agenda:_https:github.comansiblecommunityissues577
LOGS
19:00:25 <jillr> #startmeeting Ansible Diversity Working Group | Agenda: https://github.com/ansible/community/issues/577
19:00:25 <zodbot> Meeting started Thu Apr 29 19:00:25 2021 UTC.
19:00:25 <zodbot> This meeting is logged and archived in a public location.
19:00:25 <zodbot> The chair is jillr. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:25 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:00:25 <zodbot> The meeting name has been set to 'ansible_diversity_working_group_|_agenda:_https://github.com/ansible/community/issues/577'
19:00:44 <thedoubl3j> o/
19:00:56 <jillr> #chair thedoubl3j
19:00:56 <zodbot> Current chairs: jillr thedoubl3j
19:01:26 <cybette> o/
19:01:47 <tadeboro> o/
19:01:48 <jillr> #chair cybette
19:01:48 <zodbot> Current chairs: cybette jillr thedoubl3j
19:01:55 <jillr> #chair tadeboro
19:01:55 <zodbot> Current chairs: cybette jillr tadeboro thedoubl3j
19:02:10 <jillr> hey y'all  o/
19:02:18 <jillr> #topic PyCon US update
19:03:23 <jillr> Someone else sponsored the Py ladies auction before us, so we'll have to plan to get in on that quicker next year
19:03:42 <jillr> The PyCon virtual booth setup is a little different.  There's no text chat, just one on one video chats, and the ability to post links.
19:04:22 <jillr> I've already submitted the blog post about eradicating harmful language in core to opensource.com, so as long as we can gget that published before PyCon we'll link to that in the booth materials
19:04:57 <jillr> and cybette and I will be hanging out on standby for the booth on Friday May 14th if anyone wants to have a video chat about D&I
19:05:15 <cybette> Thanks jillr for getting the blog post ready within the tight schedule!
19:05:25 <jillr> np!
19:06:07 <jillr> It will be interesting to see if anyone comes by the booth, I think people are a little burnt out on virtual events
19:06:16 <thedoubl3j> awesome sauce!
19:06:35 <cybette> I will also add the link to our D&I working group in the virtual booth
19:06:47 <jillr> good call, thanks cybette
19:07:15 <jillr> We have a rainbow (lgbtq Pride) version of the Ansible logo someone internally made, so we can use that for our links
19:07:44 <cybette> Great idea!
19:07:51 <jillr> is anyone else attending Pycon?
19:08:43 <thedoubl3j> I will be
19:09:51 <jillr> cool.  right now it looks like we'll only be "staffing" the booth on Friday, if you run into anyone in any sessions or whatever that wants to chat you can point them our way that day
19:10:19 <tadeboro> I will probably skip because online stuff does not work for me for bigger events.
19:10:20 <thedoubl3j> roger
19:10:28 <jillr> or just generally send them here, or any of our usual places
19:11:11 <jillr> tadeboro: yeah I'm not a huge fan of the format either
19:12:05 <jillr> #topic Meetup organizer CoC survey
19:12:29 <jillr> We have a draft of the survey questions at the bottom of the hackmd page:
19:12:32 <jillr> #link https://hackmd.io/YiBvALjKSFqtVTXzoY-I7A
19:13:27 <jillr> it would be extra helpful if folks for whom English is not their first language could review and call out anything that might be unclear, confusing, or easy to misinterpret
19:13:45 * tadeboro gets to reading
19:14:15 <jillr> felixfontein and misc aren't here today, but maybe if they get a chance before the next meeting
19:15:53 <misc> oups
19:16:00 <misc> I forgot the meeting :(
19:16:19 <jillr> no worries!  :)
19:16:21 <jillr> #chair misc
19:16:21 <zodbot> Current chairs: cybette jillr misc tadeboro thedoubl3j
19:16:52 * misc check his excuse card
19:16:57 <misc> I forgot because of DNS
19:17:30 <jillr> hahaha we are having DNS problems with some build systems today, so I'll take it!
19:18:06 <cybette> the survey reads fine to me, but for the past 20+ years I read way more in English than Chinese...
19:18:40 <misc> same, seems fine for me
19:19:20 <misc> however, when the survey say "the raw data will be avaliable to the D&I working group, and the ansible community team", what that mean in practice ?
19:19:36 <jillr> I can also ask a few people on the cloud team (I really should have already done that, now that I think about it)
19:19:39 <misc> like, does that mean there will be a private repo to host the data ?
19:20:17 <misc> (cause I understand that part as "not everybody will have access", but I am not sure we have a easy way to share that kind of info)
19:20:21 <jillr> gwmngilfen will have the survey monkey data, I don't know if the rest of the community team does as well
19:20:49 <jillr> a private repo or a shared spreadsheet is probably the easiest
19:21:13 <jillr> once it's exported from survey monkey
19:21:31 <cybette> only Gwmngilfen has access to survey monkey
19:22:15 <jillr> are we all comfortable with having a private repo for these sorts of things?  probably under the ansible GH org?
19:22:42 <misc> private repo seems easier
19:22:51 <jillr> do we want to consider other options, or vote?
19:23:06 <misc> not sure if RHers can share spreadsheets easily with non RH people, with the corp account
19:23:31 <misc> while private repo will be inline with existing process and account, etc
19:23:37 <jillr> I think we can, but a repo is probably better anyway
19:23:42 <cybette> yeah, I think private repo might work better
19:23:57 <tadeboro> I did not find any issues with the language. My EU mind started to feel uncomfortable when I came to the email-sharing part, but apart from that, things look great.
19:24:04 <gwmngilfen> I can put the results somewhere private once the survey is closed
19:24:11 <cybette> we have summoned Gwmngilfen  :)
19:24:19 <jillr> VOTE: create a private repo on github.com/ansible for storing sensitive D&I related data (such as survey results)
19:24:26 <misc> +1
19:24:29 <thedoubl3j> +1
19:24:31 <jillr> +1
19:24:34 <gwmngilfen> Namedropping will do that :)
19:24:37 <cybette> #chair Gwmngilfen
19:24:37 <zodbot> Current chairs: Gwmngilfen cybette jillr misc tadeboro thedoubl3j
19:24:49 <cybette> +1
19:24:55 <tadeboro> +0
19:24:59 <misc> tadeboro: yeah, good point too, but that's information we already have since we send the survey to people
19:25:00 <gwmngilfen> Nah, no furniture for me, I have a cake to bake :)
19:25:13 <tadeboro> I have no need for that data, so +0 from me.
19:25:17 <jillr> oooh, yay cake!
19:25:59 <jillr> passes:  +1: 4, +0: 1, -1: 0
19:26:33 <jillr> I don't have admin on that org but I can chase down people who do
19:26:40 <jillr> #action jillr to get the repo created
19:27:07 <jillr> Do we want to get any more language reviews before sending out the survey?
19:27:13 <misc> tadeboro: since the survey say that the email will be shared with the community team, but not the D&I group, I guess that your point is taken care of :)
19:27:42 <jillr> misc: it does say it will be shared with the D&I group
19:28:06 <jillr> but anyone who doesn't want access can certainly request to not be given data access rights
19:28:13 <misc> jillr: so the raw data, but the last part: "Please provide your email address (this information will be shared with the Community Team)."
19:28:30 <jillr> oh yeah, that part
19:28:41 <jillr> sorry I mis-read your comment
19:28:44 <gwmngilfen> That's the optional one, yes?
19:28:47 <jillr> yes
19:29:04 <misc> jillr: well, there is a contradiction in the survey :)
19:29:06 <tadeboro> I am more concerned about the "how I can get my data removed" part. But if we already have the email address, this issue is probably already solved.
19:29:35 <jillr> misc: we can also ask the emails be stripped from the results before being put into github, though that's more work for gwmngilfen
19:29:46 <misc> yeah, I think that would be safer
19:29:58 <gwmngilfen> Dropping one column from a CSV is not a lot of work :)
19:30:07 * tadeboro has still nightmares from the GDPR process changes ...
19:30:09 <cybette> +1 for stripping emails
19:30:15 <jillr> we (the working group) are more concerned with overall sentiment/trends, whereas the community team would be the ones following up if needed
19:30:26 <misc> now "which meetup do you organise" also mean people can be found
19:30:36 <jillr> we can also strip that column
19:30:50 <jillr> but, we should update the language in the survey then probably
19:30:54 <gwmngilfen> Tadeboro: the raw data also has IP/timestamp which I will not push up, but can be used to identify a record if it needs deleting
19:31:52 <jillr> I added an "only" to the lines about (this info will be shared with thecommunity team) on those questions
19:32:11 <misc> also, not sure if I already said (didn't seems so), but maybe the aggregate part could be explained
19:32:29 <gwmngilfen> "Results summary"?
19:33:04 <jillr> "summary of results from all respondents"?
19:33:21 <misc> no, I mean more will we be showing a average scale, or a count of incident, or something ?
19:33:27 <jillr> like my thinking there was we might share a report in a contributor summit
19:33:45 <jillr> or discuss the aggregate info in this meeting
19:33:52 <gwmngilfen> Something like that, yeah. Nothing identifying
19:34:02 <jillr> "wow, 50% of the meetup organizers who repsonded reported X!"
19:34:37 <cybette> no PII or MGII (meetup group identifiable info)
19:34:44 <misc> ah ah
19:35:45 <misc> but I guess it could help to tell in advance what are the aggregate. we know that gwmngilfen will be careful, but I guess lots of meetup organiser do not know
19:36:13 <gwmngilfen> That's fair.
19:36:43 <jillr> maybe like, 'The aggregate results (for example, the percentage of respondants who answered "yes" to a question) will be made public'
19:36:57 <misc> yeah, something like this
19:37:47 <misc> (wow I am really tired, I started to wonder why the text was moving by itself on hackmd...)
19:37:53 <jillr> hehe
19:38:23 <jillr> how about that?
19:38:31 <cybette> jillr working magic on the text
19:38:38 <misc> jillr: seems good
19:39:04 <cybette> looks good
19:39:15 <misc> I also wonder if the 2nd question with 5 "extremely confident" could be clarified, to avoid people thinking they are confident while they might not :/ (or if that's what we want to measure)
19:39:30 <misc> for example "5 (I already handled and/or was trained)"
19:39:50 <jillr> yeah I like that
19:40:35 <gwmngilfen> +1
19:42:38 <misc> if people didn't report, should we ask why, or would it be scope creep ?
19:43:48 <jillr> what would be the proposed responses?  I can see "didn't know how", I'm not sure offhand what else we would look for
19:44:19 <misc> "I think this was important", or "I didn't found the place", or "I forgot"
19:44:20 <jillr> "didn't feel comfortable reporting" but that's probably not the best phrasing to get useful data back
19:45:36 <misc> I guess a textbox would allow to ask that as a exploratory question ?
19:45:53 <misc> but that's also part of the follow up
19:47:42 <jillr> I added that in, thoughts?
19:47:46 <cybette> I think that works (the changes in hackmd)
19:48:22 <jillr> does "Why did you not report the incident?" read ok?  it feels like awkward phrasing to me...
19:48:51 <misc> yeah, I think that's a bit inquisitive
19:49:00 <misc> (but well, that's the goal)
19:49:00 <jillr> the grammar of "why didn't you" vs "why did you not" is weird... english is weird :)
19:49:28 <jillr> "Why was the incident not reported?"  maybe?
19:49:39 <jillr> or I guess we could just say "why not?"
19:50:37 <cybette> "Why was the incident not reported" sounds less accusing.
19:52:08 <misc> mhh yeah :/
19:52:38 <misc> so maybe this could be for a 2nd survey ?
19:53:07 <jillr> like, do you think we should do a second survey for people who report that they have had an incident?
19:53:22 <jillr> regardless of whether they reported it
19:53:27 <misc> more if we do a survey in 1 year ?
19:53:35 <jillr> ah
19:54:02 <misc> once people are more familiar with the idea of having a survey on D&I, it might sound less accusing
19:54:02 <jillr> I'm ok with keeping this one short and simple, but also want to make sure we ask the questions that are important to folks
19:54:13 <jillr> that's a good point
19:54:21 <cybette> +1 keeping this first one simple
19:54:25 <misc> and we do not know yet if there is something to investigate
19:54:31 <cybette> right
19:54:36 <jillr> shall we lose the question about why things weren't reported?
19:54:41 <misc> yeah
19:55:36 <cybette> I'm fine with that
19:57:35 <jillr> anything else we want to add, change, reword, etc before we send the survey out?
19:57:54 <misc> the closing date ?
19:58:10 <jillr> 14 days from when we send it out maybe?
19:58:18 <misc> seems good yep
19:58:36 <jillr> do we need to put that into the text of the survey, or into the message that gets sent out?
19:59:01 <misc> both ?
19:59:08 <cybette> I'll send it out with the message. we don't usually put the deadline in the survey.
19:59:28 <cybette> (at least with the previous contributor surveys etc.)
19:59:45 <jillr> I'll defer to cybette's superior survy wisdom  :)
19:59:53 <jillr> also her survey wisom
20:00:05 <jillr> (I'll just stop trying to spell now!)
20:00:38 <cybette> hehe
20:01:12 <cybette> gotta drop for another meeting
20:01:15 <cybette> thanks jillr and everyone!
20:01:24 <jillr> gwmngilfen: we're ready with the questions and answers in the hackmd doc, thanks!
20:01:28 <jillr> thanks cybette
20:01:56 <jillr> one last quick item that I forgot to put in the agenda then...
20:02:09 <jillr> #topic  Code of Conduct Incident Response Workshop
20:02:46 <jillr> several members of Ansible staff have been scheduled (and paid for) to attend the otter tech workshop on June 5th
20:02:57 <jillr> we shall report back afterwards
20:03:31 <jillr> #topic open floor
20:03:37 <jillr> anyone have anything else?
20:03:54 <misc> nothing for me
20:05:34 <jillr> #endmeeting